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Introduction to TwoTrails Timber Cruising Surveying

TwoTrails is a timber cruising and timber sales admin surveying package. It is maintained and developed
by the Forest Management Service Center. Though it is specifically written for USDA forestry personal, it
is freely available to anyone. Many of the program capabilities are shared below:

e Manages all surveying methods approved by USDA Forest Service Handbook, FSH 2409.12,
Chapter 50, Area Determination.
e Real-time GPS surveys:
o GPS Walk (Breadcrumb)
o GPS Angle Point (Take5)
e Real-time surveys:
o Direction Distance Traversing
o Radial (example: Island Exclusions)
o Corridors (example: Hazard Tree)
e Combined use of multiple survey types:
o GPS surveys
o Digitized Information (Shape Files, KML/KMZ, GPX, CSV)
o Remote sensing information
e Create Grid (Sample) Point sand Navigate to them
e (Can use .ttx (Android) and legacy .tt2 (TwoTrailsV2) projects
e Exports:
o GIS Shape Files
o KMZ and GPX
o Project Status and Information
o CSV’s (Points, Polygons, Metadata, NMEA Information, etc..)
e Automatically calculates area-error for comparison with handbook standard
e Live visual mapping with point creation and modification
e Full support to Forest Service personal via Forest Service Management Center (Support to
others is available as well when resources allow)



Basic Operation:

There are two main ways the PC application is used. One way is to design a project for field use. The
other way is to process incoming data from the field. Multiple projects can be opened at once in
TwoTrails. It is a best practice to use a copy of the original data for editing.

Saving Files

e File -> Save

e Shortcut: Ctrl +S

e Do this as your changes are not automatically saved.

e An asterisk will appear after your project’s title on the
project tab when data has been edited and needs saving.

Opening Files
e File->Open
e Shortcut: Ctrl+ O
e Dragand Drop TTX or importable file type into the TwoTrails Window

Creating a Project
1. File -> New
2. Enter the project information as well as filename and location

3. Select Create



Project
e Project tab contains all the descriptive information about your project.
e On the right side you are able to see the total number of Points, Polygons, Metadata and Groups
that are within your project.

e  Multiple Projects may be opened at one time. Make sure that you are in the correct project
before making changes.

P8 TwoTrails - Demo Project - [m] X
File Edit Data Tools Help

Demo Project X

Project Data

Demo Project Points 12
Region Polygons 1
6 Metadata 1
Forest Groups 2
District

Description
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Metadata

e Fill default metadata with your project definitions.

M TwoTrails - Demo Project
File Edit Data Tools Help
Demo Project %

g Default MetaData Name

] Default MetaData
g Declination Type
ks MagDec

g Distance

o

S FeetTenths

z Slope

o

g Percent

B GPS Reciever

o]

2

E Compass

z

g

- Comment

z

3

B

Delete New

UTM Zone
10
Declination

0

Elevation
FeetTenths
Datum
NAD83
Range Finder

Crew

24 Points use Default MetaData

e To create a new metadata profile select New on the bottom of the metadata list.
e Points and polygons associated with the metadata are automatically updated with the changes as
you edit them except for the UTM Zone. If the UTM Zone is to be changed, then modify the new

value and press Update to complete the operation.

e When you change a point’s metadata definition the point will also be updated automatically.




Polygons

A polygon must be made for each unit. It also used for each feature such as grid points. A project can
contain multiple polygons which are displayed in the polygon list. Selecting a polygon in the list allows
editing of that polygon.

e To create a new polygon select New located on the bottom of the polygons list.

M TwoTrails - Demo Project - m] X
File Edit Data Tools Help

Demo Project %

5 Poly 1 Name Area

]

2 Poly 1 .

g /\ddon Acc)l/.lrac (Meters) e 06869

- Y Ac: 1.6974

@ 6.01 | Update | Acc Lookup ||

g Start Index Polygon Perimeter

E 1010 M: 314911
I t

z neremen Ft: 1033.170

2 10

[*8

B Poly Line Perimeter

o Created On: 3/7/2018 11:08:23 AM M: 306.467

(o]

3 . Ft: 1005.468
Description

Z
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3

@

Polygon Area-Error Summary

GPS Contribution* Traverse Contribution
Ha: 0.1893 Ha: 0.0000
Ac: 0.4677 Ac:  0.0000
Err Ratio** 27.554% Error 0.000%

*Or perimeter error such as taping error
**Area-Error/Area to be less than 10%

I Delete | | New ||

12 Points in Poly 1

e Poly area-error information is located at the bottom of the Polygon form. Details shows more
information about individual point’s errors and individual traversing errors. (This is the same as
How Am | Doing on the mobile device).

o Fields are initially populated. Modify as appropriate. All information is automatically updated
except for the Accuracy. To update the accuracy press Update.



Your measurements specialist should be
contacted for accuracy information. The
Accuracy can also be changed via the Acc
Lookup tool. Here you can select your
device’s make and model and the canopy
option that you are collecting your data in.
When you are done selecting your accuracy
value in the Acc Lookup, press OK.

nAccuracy Information
MTDC | RangeFinder / Tape

Make | Trimble

21 Model Geg 7)( 3

v

Accuracy |6.01

Ext Ant SBAS Positions

Glonass Post Proc Open Acc Med Acc  Heavy Acc

False |None |1 True False 177 5.21 5.03
False |None |5 True False 112 3.16 5.3
False |None [60 True False 2.03 648 4.76
False |None | 180 True False 5.94
False |None |1 True True 0.41 317 373
False None |5 True True 0.27 1.8 3.81
False None |60 True True 0.24 3.11 3.54
False |None | 180 True True 2.88
False |WAAS([1 True False 0.71 1.65 376
False |WAAS|5 True False 1.02 245 5.49
False | WAAS|60 True False 0.67 2.88 3.49
False |WAAS| 180 True False 5.94
False WAAS[1 True True 0.46 1.34 3

Cancel

(o]




Points

Modify Points
e To modify one or more points simultaneously, first select them in the points view. Then located
in the right panel, enter the new value of the property you want changed.
e TwoTrails PC auto adjusts polygons as you edit points. The changes made to
area/perimeter/error will be updated without the need to close or save your project or window.

Ml TwoTrails - Demo Project - O X
File Edit Data Tools Help
Demo Project % Points Filter
® Polygons OpTypes Groups Metadata
Ll 7 Al Al ~| & Al Al '] On Boundary
= Poly 1 GPS Main Group Default MetaData ™ Has Links
g Addon Faverce Take5 9a5021b7
- WayPoint
g Quondam . Property Editor
[(=}
5 Index [PID | OpType | Polygon OnBound |AdjX AdjY AdjZ (M) | Acc (M) | QndmLink @Default
. o 1010|Take5  |Poly 1 True 693626.368|4709924.096(18123  [6.01  |True pio 2010
z K 1015|Take5  |Poly 1 True 693634.345|4709947.655{1789.8 |601  |False
Sl 2 [1020[Take5  [Poly 1 True 69367184 |4709983.891|1779.1 601 |True Polygon | Addon N
. 3 1025|Take5  |Poly 1 True 693683.082|4709973.794[1771.18 [6.01  |True Index 0
o I 1030|Take5  |Poly 1 True 693718.25 |4709945915(1765.1 |6.01  |True
! Metadata | Default Met ¥
£ 1B 1035|Take5  |Poaly 1 True 693725.329|4709927.886(1767.66 |6.01  |True
“ B 1040|Take5  |Poly 1 True 693726.452|4709907.247[1767  |6.01  |True Group | Main Group *
E 7 1045|Take5  |Poly 1 True 693707.288|4709896.712|17687 601  |False OnBound
5 I8 1050|Take5  |Poly 1 True 693680.121|4709888.176(1784.2  [6.01  |False
9 |1055|Take5  |Poly 1 i 693666.516|4709874.832|17956 601  |False UnAdjX |693671.835732]
10 |1060[Take5  |Poly 1 True 693647.359|4709883.746|1796.1 [6.01  |False UnAdjY 4709983.89083¢
11 [1065|Take5  |Poly 1 True 693625.231(4709915.729(17994 [601  |False Unadz [5836.93058333]
0 010 Quonda Addo = 6936 84 4709983.89 9 6.0 alse
1 2015 |SideShot |Addon True 693683.514|4709993.687|1779.1 |601  |False Man Acc
2 2020|Quondam | Addon False 693683.082|4709973.7941771.18 [6.01  |False fwd Az
3 2025|SideShot |Addon True 693709.479|4709989.034[1771.18 [6.01  [True
4 |2030]|Quondam |Addon False 693718.25 |4709945915(1765.1 601  |False Back Az
5 2035 |SideShot |Addon True 693733.924|4709964.595(1765.1 [6.01  |True SIp Dist
6  |2040|Quondam|Addon False 693725.329|4709927.886|1767.66 |6.01  |False Slp Ang
7 |2045|sideshot |Addon True 693737.521|4709927.886|1767.66 |6.01  |False
8 2050 | Quondam | Addon True 693726.452|4709907.247[1767  [6.01  |False Qndm Link
9 2060 |Quondam |Addon True 693725.329(4709927.886|1767.66 |6.01 False Comment
10 |2070|Quondam [Addon True 693718.25 |4709945915(1765.1 |6.01  |False
11 [2080|Quondam|Addon True 693683.082|4709973.794|1771.18 |6.01  |False
@ Extended




Create Points (Manual Coordinate Entry)
To create points, go to Tools -> ‘Create New Point’ and select the type of point you want to

1.

5.

create.

Insert location tells the program
where to insert the point.

In the GPS creation tool, you have
the ability to select from UTM or
Lat/Lon as the location value. By
choosing Lat/Lon, your value will be
converted into UTM based on the
Metadata that is selected.

In the Traverse/Sideshot creation
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Recalculate All Polygons Ctrl+Shift+R
_Create New Point » GPS ad
Create Quondams Ctrl+Alt+Q WayPoint
Move Points Ctrl+Alt+M ‘M
Retrace Points Ctrl+Alt+R Traverse
. i SideShot
Create Grid Sample Points Ctrl+Alt+P
Create Corridor t Quondam
Modify Data Dictionary djy AdiZ (M) | Acc
Settings 709924.096(1812.3  |6.01
= - 1. = PP PP P -

tool, Distance and Angle are based on the Metadata’s units of measurement.

n Create GPS
Information & Location
PID (Auto)
OnBoundary

® UTM QO Lat/Lon

UTM X

UTMY

Elevation (FtT)
Manual Accuracy

Comment

Cancel

X

Insert Location
® End O Begining
O After Point

Polygon
Poly 1 d

Metadata
Default MetaData ¥

Group
Main Group Y

Information & Location
PID (Auto)

OnBoundary

Forward Azimuth
Backward Azimuth
Slope Distance (FtT)
Slope Angle (Percent)

Comment

Create |

| Cancel |

Insert Location
® End O Begining
(O After Point

Polygon

Poly 1 &
Metadata

Default MetaData

Group

Main Group v

Enter the values into form and then select Create.

Quondam/Move Points
1. To Quondam or Move points first select the points

4.

in the list.

Go to Tools -> Create Quondams or Tools -> Move
Points. (Alternatively you can right click the
highlight points and select Quondam or Move)

In the window that pops up select the direction to
guondam or move the points into the target

polygon.
Hit Commit to finish.

n Quondam Points

Action
® Quondam

O Move

Direction
® Forward

O Reverse

Cancel

Target Polygon
Addon v

Insert Location
® End O Begining
O After Point
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Retrace Points
The retrace is an efficient method of retracing many segments of points.

Notes:

Go to Tools -> ‘Retrace Points’.

In the Retrace tool select the Target Polygon into which to insert the quondam points.

Then select the location to insert the quondam points in that polygon (Almost always the End)
and whether or not the quondam points will inherit their parent’s point boundary value.

In the section below set the polygon, from which the points will chosen. Then select the start
point, the end point and whether the direction will be Fwd (from 1010 toward 1020) or Rev

(from 1020 toward 1010). Single will only take one point from the polygon.

To add another point segment, click the + symbol on the right of the segment list. Click — to

remove a segment.

When all segments are created, click Create to commit the changes to the target polygon.

H Retrace

Target Polygon Insert Location

Poly 1 v ®@End O Begining O After Point

Poly 1 v | 1010 (Take5) @ Fwd O Single ORev | 1060 (Take5) v
Poly 1 v | 1060 (Take5) ¥ O Fwd O Single ®Rev | 1020 (Take5) “

— O X

Boundary
@ InheritO On O Off

[ 0]
0]

Cancel

Point segments can be created in a loop with the starting point that is further down the polyline.

Ex: 1050 -> 1020 in the forward direction would produce a segment: 1050, 1060.., 1010, 1020.
Ex: 1020 -> 1050 in the reverse direction would produce a segment: 1020, 1010.., 1060, 1050.
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Other Point Actions

Delete Points

e To delete one or more points, select them in the points table. Then go to Edit->Delete or
press the Del key to delete the point.

Reset Points
e To reset one or more points, select them in the points table. Then go to Edit->Reset Point or
press the Ctrl+R to reset the point(s).
e Resetting points will change all their properties to their original state when the project was
last opened or saved.

e Selecting Discard all changes will reset all the points in the project to their saved or opened
state.

Converting Points
e Certain points can be converted from one type to another.
e Points that can be converted include Traverse <-> SideShot, and Quondam->GPS.
e To convert a point go to Edit->’Convert to XXXX’ or right click on a point and select Convert
in the menu.

Creating Corridors
e To create a corridor, select all the points that are within the corridor (Take5, GPS, SideShots)
e Then go to Tools->Create Corridor or press Ctrl+Alt+C.
e The corridor will automatically be created and adjusted.

Other Information:

e Data in the points table can be undone/redone using the Edit->Undo/Redo or Ctrl+Z and
Ctrl+Shift+Z respectively. Polygons/Metadata/Groups/Media do not have this functionality for
the editing and creating.

e You can reverse a section of points by selecting them in the points table and going to
Edit->Reverse Points or right clicking on the points and selecting Reverse.

12



Plot Grid

To create Sample Points go to Tools->'Create Grid Sample Points’ or press Ctrl+Alt+P.
Select the polygon in which you want to place sample points.

ok wNnN

Notes:

Select a Start point from the list or leave blank for a random start.

Choose the unit of measure for distance then input the distance in the X and Y boxes.
You can select to tilt the grid by. (+/- 45 degrees)

Next select Generate to create your plots.

Delete Existing Plots will delete your old
plots and generate new ones in their place.
If this is not selected, Plots will be generated
in a new polygon.

Sample is rarely used, but will select either a
percentage or amount of points from the
total generated points.

H Create Grid Sample P.. —

Polygon Retrace
Start Point

UOM Distance | FeetTenths

. X
Grid Interval 100
Tilt Y Axis (-45° < +45°)
[ ] sample Percent

Boundary Buffer
Delete Existing Plots

Close

| X

3010 (Quondam): 1040 (Take5) ¥

Generate

13



Mapping

TwoTrails has a built in map that is automatically updated as points and polygons are edited.

e On the left side of the map is the polygons list which contains the individual polygon visual
settings. Pressing the icons allows points and lines to become visible.
e From the top left to bottom right the icons are:

o Adjusted Boundary, Adjust Boundary Points, Unadjusted Boundary, Unadjusted Boundary
Points

o Adjusted Navigation, Adjusted Navigation Points, Unadjusted Navigation, Unadjusted
Navigation Points

o Way Points, Adjusted Misc Points, Unadjusted Misc Points

3 TwoTrails - Demo =8 EoR =™

File Edit Data Tools Help
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e The check box in the top right of the individual polygon cards is the master switch which turns
all of the points/lines on and off for that polygon.

e The ZT button zooms to an individual polygon filling the entire map.

e The box with an arrow in it on the left tab that says Map allows the map to detach from the
main window. This allows the map and points to be visible side by side.
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e The Map is live and polygons will change shape as points are created, edited or moved within
the project.

P8 Map - Demo 28 TwoTrails - Demo =R =)
[15] X: 42821463 Y: 3851055.18 File Edit Data Tools Help
PU25A Demo X
E ) Polygons Oplypes Groups Metadata
bl Pu2A |=man - [@an (@A | ™ On Bounc
@ A E 7 GPS & | ¥/ Main Group 7| Metal | 8 Has Links
PUSA i
@ @ > Bl = 9] Take58ba5989f
ey | ke 9] Take56348afb7
Bl s FOND) 7 WayPoint 7] Take522be5597
! ® - | @ Quondam  ~ |[¥ TakeSc1f89288 -
PU25B s - L g
E @ EW index | PID | OpType | Polygon OnBound | AdX AdjY AdiZ |~ Default A
Bl 1 [13110[Takes [PUSX(POND) [Tve  [428100631[3851029 603[2083 - vits (5155
O] Bl 8l 5> [1310[Takes [PUSX(POND) [True _[42811125 [3851023.12 [3027 =
=8 23 [13120[Take5 [PUSX (POND) [True 428108557 | 3851013.345|30.33 Polygon [PUSX (PO -
@ Bl 24 13130/ Take5 |PUSX (POND) |True 428112.604] 3851003.856/ 29.57 Index |34
) 5 [1300[TokeS [PUSK (POND) [Tve __ [428114675[385099600612921 | .. (et +)
POZ % 26 |13140[Take5 |PUSX (POND) |True _|428120.502|3850990.641[29.39 et
27__|13140[Take5 |PUSX (POND) |True __|428128.861|3850990.658|29.69 Group |Main Gro. v/
28 |13150|Take5 |PUSX (POND) |True __|428142.442|3850994.287|30.03 9l
§_ ke5 P T OnBound
3l 29 [13150|Take5 |PUSX (POND) |True |428153.583|3851000.382|29.82

UnAdjX 428

30 |13160|Take5 |PUSX (POND) |True 428165.087|3851005.337| 29.94
31  |13160|Take5S |PUSX (POND) |True 4281845 |3851011.686/30.11 UnAdjY | 3851037.52:
32 |13170|TakeS [PUSX (POND) |True 428187.439|3851023.26830.07,
33 13170| TakeS [PUSX (POND) |True 428196.578|3851033.462|29.94

BEE;
Clelok
EEE

m

UnAdjZ | 98.

PU23A 34 [13180 TakeS [PUSX(POND) True  428209.194 3851037.523 29 Man Acc

E 35 [13180[TakeS [PUSX (POND) |True 428211.852(3851043.207(30.32 Fwd Az
36 13190|Take5  |PUSX (POND) |True 428224.837|3851051.134|29.83

m 37 |13190[TakeS [PUSX(POND) [True  |428228627|3851055.566(30.11 Sacenz

[0] @ 38 [13200|TakeS |PUSX (POND) |True  |428233.576|3851056117]30.16=|  SIp Dist
39 13200|Take5 |PUSX (POND) |True 428245.626|3851062.198/30.23 Slp Ang
40 13210|TakeS |PUSX (POND) |True 428251.329|3851064.518)30.36

41 13210|Take5 [PUSX (POND) |True 428258.384|3851077.498|30.01 Qndm Link
42 |13220|Take5 |PUSX (POND) |True 428279.024|3851083.485|30.52 Comment
43 |13220|Take5 |PUSX (POND) |True 428290.933|3851091.326|30.22
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Export

1.
2.
3.

To export points go to Data->’Export Project’.
Select the output location under ‘Folder Location’. (By default it is the location of your project)

Select the files you want to export and then press the Export button. A folder will be generated

with all your files inside of it.

Exportable File Types

Points (CSV)

Data Dictionary (CSV)

NMEA (CSV)

Polygons (CSV)

Metadata (CSV)

Groups (CSV)

Project (TXT)

Summary (TXT)

Google Earth (KMZ)

GPS Exchange (GPX)

Shapes (GIS: SHP, PRJ, DBF, SHX)
Media Info (CSV)

Media Files (JPG, BMP, TIFF, GIF)

n Export

Folder Location

C:\Users\ Name\Desktop

[m] All

Points

+/| DataDictionary
NMEA
Polygons
Metadata
Groups

Cancel

X

Project

Summary
KMZ

GPX
Shapes
Media Info
[ ] Media Files
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Media

Viewing Collected Media
Click the Media Tab on the left of the application. The select on the point which you would like
to view media from.

’ TwoTrails - Demo
File Edit Data Tools Help
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image in
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of the
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image list.
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